Text in hints for LingQed words disappearing and sometimes unable to see LingQs for words in yellow

When I review previous lessons and want to review some word, the notes I have written in the hint section have disappeared. I can sometimes get them back by clicking on the word in the LingQ list but other times even this doesn’t work. When I write the notes I diligently click on the save button and even check if it was saved by going back and forth between different words. However they are gone when I later come back to the lesson. Also when I click on several words in a lesson I sometimes loose access to a word, the word is in yellow in the text but when I click on it I see the definition for the previous word. Even clicking on the word in the LingQ list or trying to get to the word using the arrows doesn’t work. This is very annoying!

@GiMurphy - That sounds strange. When you click on a yellow word in the text, are you seeing the term information in the dashboard at right? Is it only the Hint that is missing? Do you see the Phrase for instance or any tags you have added or the status? What information do you see? Which browser are you using? Have you tried refreshing the page when you are unable to see the hint or when you are unable to open a LingQ? Does this resolve the issue?

@mark - yes only the hint is gone, refreshing the page doesn’t help. I am using Firefox 15.0.1. I forgot to mention that when I receive my e-mail ‘LingQs of the day’ I can see which words have a problem as the hint is missing there also (got one again this morning!). I noticed yesterday that sometimes when I add notes to a hint, these additions disappear, the original text remains.

There are some yellow lingqs, hints of which I can’t see by hovering over. Sometimes page refreshing helps.

What makes really nervous is that you never know, if that’s just the hint not appearing or has the hint not been saved (which also happens).

The same has happened to me several times. And it makes me nervous too and prevent me from working seriously on LingQ at the moment… Instead I translate the interface into German.

@GilMurphy, Vera, Eugrus - We are unable to make this happen. Are these hints that you created in the last few days? If they were created before that, there were some issues that prevented saving of hints when Enter was not pressed but all those issues should be resolved now.

Occasionally, and very occasionally, I open a LingQ and find no Hint. I usually assume that I forgot to put in a Hint, or forgot to save the Hint, but it is also possible that this is a bug. We will look into it.

However, it happens so rarely, and the solution is simply to put in a Hint again, and that probably helps me learn the word faster, that I cannot see why this would prevent anyone from using the site.

On the other hand Vera, I really appreciate you helping us with the translation of the interface.

I tried adding notes to a lot of LingQs. There was no trouble. I might add for those who add notes, I am one of those, note that as you review your yellow words, the system remembers what you last looked at. It is sometimes useful to review your yellow LingQs just looking at your notes, and then reviewing the LingQ looking at examples. Variety is the spice of life, and it keeps the brain involved.

Here is the last instance of the problem. The lingq the hint of which was not saved after pressing Enter was for the phrase “geltend machen” (however, the problem appears not just with phrases)

Here you can see my Firefox Error Console: http://s14.postimage.org/ffexhid67/empty_lingq.png

And here is the web console’s log: The lingq which hint was not saved after pressing Enter - Pastebin.com

Now I had this problem again with the lingq’s for the word “ausgeschöpften” hint.

@eugrus - Thanks for the logs. We’ll take a closer look into this and see if we can find out what might be going on here.