Tag filtering not working


I can’t get the tag filtering to work for me, at all. I followed the instruction video in Academy but when I add a filter term it doesn’t “stick” as it does in the video. I’ve been a member for 2+ months now, and have tried this several times, to no avail. I would like to use it. What is wrong?

I am using the latest version of Chrome, on Mac Big Sur v11.6


I tested on my end (Chrome browser) and it seems fine. On the Vocabulary tab, under the filters, you will see a list of all tags you have used when saving words. Just click on a tag, and all words that have that tag will be listed below. Can you please give it another try?

Thanks you.

Your response didn’t deal with the issue, which I may not have explained clearly enough, but in any case in fiddling around with the Tags further this morning in order to explain the problem in more detail, I stumbled across what I was doing wrong and fixed it. Now I can tag words after all.

Problem solved. Sorry to have bothered you.