Stress marks in Russian dictionary entries

Is it possible to mark the stress in Russian dictionary entries for LingQs?

  • using an apostrophe (') does not work, as these are edited out by the software

  • using a capital letter (as in выУчивать, вЫучить works for headwords with a space or comma (as shown) but not for singleton words, such as предАние. The capitalizing is “corrected” by the software.

Inability to mark the stress makes the LingQs less usable as flashcards, so I hope it’s only my ignorance that’s the problem here.

(I searched the forum for previous discussion of this but only found passing reference to it.)

I used LingQ for my Russian learning and found that I gradually got used to the stresses with enough listening. And in those days we did not have the Text to Speech on our flash cards and on our Lesson page that we have today. I suggest you click on the TTS and trust that you will gradually get used to the stresses.

Some dictionaries such as word.ref have stress marks in them, that you could copy over when getting your definition. You’ll get used to the stress in time though. I just mark the occasional word that seems irrergular or doesn’t have the stress where I ‘feel’ it ought to.

Thanks for your replies.

. . . gradually got used to the stresses with enough listening.

In this case, I’m using a text without a recording. I haven’t noticed the TTS feature. I’ll look for it.

Determining what the stress should be is not a problem for me. Putting it on the LingQs–so that I can test myself on it in, say, two weeks–is, as what I tried seems to disappear in most cases, as I said. It’s not a big deal. It just seems like a drawback to the LingQs, as flashcard substitutes.

[Removed this, as it was a duplicate of the prev. post.]

Ernie, I do suggest you test yourself against the TTS which appears on the flash cards and in the text of your lessons when you hover over a word.

I sometimes add the stress in the hint by capitalising the stressed vowel. Usually I don’t bother though - when you start listening to a lot of material, you get to hear a little voice in your head reading all the words out to you.

Does it work if you add the actual stress mark, i.e. выу́чивать, вы́учить?

Thanks, all, for the responses. I apologize for replying slowly.

Steve, The little TTS horn shows up grayed out on my flashcards. It that feature only available above “free membership”?

skyblueteapot, Thanks. I have done this on occasion, and it is definitely better than not marking the stress, if there is no sound to hear, which is the case I’m considering. This time around I’m trying single quotes, as at this site: . Use the entire link between < >, removing any blanks. On the page, enter, using no captial letters or special characters, a word to conjugate or delcine and click “Посмотреть” to get a response w/ accents marked .

astarmoore, How are you entering the accent marks? I could try that and see how they show up on the flashcards. I’d certainly like to know how to enter accented Cyrillic characters in these text-entry boxes.

All, the flashcards I entered today so far have kept the single quotes I have been using to mark the accent. Perhaps I was hallucinating, originally? Maybe flashcard entry parsing has changed? (I’d bet on the former possibility, myself.) In any case, thanks much for your replies. It’s nice to talk w/ you.

Hi Ernie,

TTS shows up on the flashcards for all members, right next to the term. Note that it only shows on the front of the card.

The TTS icon only becomes grayed out when the TTS audio is playing, but should return to normal after the audio finishes playing. What words are you having troubles with?

Hi, Alex,

None of my flashcards play any sound. Try the one for висячий . I hope that link will work for you, but looking at it I have my doubts.

I was wrong, however, in my earlier description. The “horn” does not start grayed out. It’s just gray, and when left-clicked it becomes lighter for 5 seconds or so and then darkens again. However, I hear nothing during this time. The regular playing of sound files works well enough.

Thanks much for checking. I suppose I have something configured wrong here.

Are you by chance using Safari? Last week someone reported an issue with Text-to-Speech for languages that use non-Roman scripts (Russian, Korean, Chinese, etc.). We have this issue on our list and hope to get to it shortly, but in the meantime you may want to try reviewing your flashcards in another browser (Chrome, Firefox, etc.)
If you aren’t using Safari, then let me know and I’ll get some further data from you to help us track down the issue.


If you’re on Mac OS, you can use the Special Characters palette (at the bottom of the Edit menu in almost any app). Search for the character called the Combining Acute Accent. Double-clicking it will place it over any character.

Astamoore, I’m on an IBM-type PC, however, so your suggestion won’t work for me. I looked around last night for “combining acute accent” and “dead key,” &c, &c, but so far have not worked out how to enter these for Cyrillic on this machine (although I did learn how to enter macrons in VIM, the editor I usually use, which will help w/ Latin–a definite plus). Thanks much, and best of success w/ your studies. From your profile, I see you’re learning Swedish. I hope that’s going well.

Alex, I’m using plain IE9 (sorry, I should have made that clear). I’m running on Windows 7 “Ultimate.” I have an old Windows XP system, too, using IE?; if results are different w/ that I’ll let you know.

(After the typos I made last night, maybe I should “Post and submit for correction”! :))

Alex, I just checked my Windows XP system, which is running IE8. The TTS does not work on it either from the flashcards–the “horn” icon color lightens for about five seconds and then returns to its original state, just as on this computer. The sound for the lessons works fine.

OK, thanks for the additional information. We will be sure to get to the bottom of this!

Even native speakers make mistakes, even more so when we’re tired :slight_smile:

Thanks much. Best of success! Any more info I can give you, please ask.

[removed duplicate post]

alex, TTS now works on my LingQ’s. I just tried it today for the first time in several weeks. If you got it working, thanks very much. (Even if you didn’t but you tried, thanks very much.) I also installed the Apple Qucktime player, to be able to use iTunes, yesterday; perhaps that had something to do with it, if you have not changed anything.

Excellent, thank you for the update! It appears the problem is in fact related to Quicktime not being installed. We’ll see what we can do from our end to make this more compatible with other media players (Windows Media Player, for example).