Strange behaviour

My FF is having a strange behaviour:

  • when I try to answer messages in my wall, my replies don’t show up, though there is a number 1 next to Comment
  • when I try to reply, the cursor keeps spinning forever
  • the button to give roses to lessons is missing

I’ve cleaned my cache, but the problems remain.
In Chrome things are working fine, but I usually prefer FF.

Hmm, I’m not immediately sure what would be causing this. I checked in Firefox on my own computer and it seems to be working properly. If it’s still giving you trouble, would you be able to check the error console and see if any errors are appearing? If so just copy and paste them here or send them to us via email :slight_smile:

Thanks! I’m still not sure what this is caused by, but I’ve passed this over to our development team and will follow up with you when we’ve made a bit of progress here!

Would you let us know if you’re still experiencing this issue in Firefox?

Hi Alex
I’m afraid so, nothing has changed.

We’re taking another look into this one. We haven’t had any other reports of it, but we want to make sure this one gets resolved.

If this is still happening, would you be able to go to and let us know if any errors appear in the console?

Hi Alex, sorry, I didn’t see your post before. Having started the thread and replied twice, shouldn’t I be “watching the thread”? Another weird behavior.

I’ll take a look at that page and post any errors here.

When I click on console I get this:

Thanks! I’ve passed this along to one of our developers and will let you know what I hear back!

OK, unfortunately we still aren’t sure what is causing this issue. The social buttons seem to be loading properly, as there is no error appearing that is related to these.

One of our developers suggested that you use Firebug, which would help us further track down this issue. Normally we don’t ask this, as the issues tend not to be so tricky, but in this case we haven’t had any luck trying anything else, and we want to get this working for you.

In Firebug, would you try and click on the things that are not working then check the error console and see if anything shows up?

Also, it would be very useful to know which operating system and which version of Firefox you are using.

Hi Alex, I’ve found
but also a firefox addon,
which one do you mean? or are they the same?

I have windows 7 and Firefox 35.0.1

They’re the same thing - sorry, I should have included a link!

No problem. Some screenshots:
Before I write a comment:
After writing a comment:
In one of SIlvia’s lesson - I don’t have the button to send a rose:

Let me know if you need more examples

Thanks, will be in touch shortly!

OK, after further investigation it seems most like that it’s either an add-on in Firefox or some settings in Firefox that are blocking some of the JavaScript on the page, which is resulting in these errors. We tried Firefox 35 on Windows 7 on a couple of devices and there were no issues, so it doesn’t seem to be specific to the OS/browser combination.

Would you try temporarily disabling all your add-ons in Firefox to see if any of these is responsible? If not, it’s possible it’s related to some settings in Firefox, though try the add-ons first and let us know what happens!

Good catch! :slight_smile: It seems I have to blame Adblock for the problems, they have vanished. Sorry for the trouble!

Ah, I see. Perhaps just disable AdBlock for LingQ then :slight_smile:

Sure! Thanks again!