Some problem when importing a text

Just after clicking “Save”, I have seen the following error message.

Script conversions form error:

* Field "script": This field is required.

Translations form error:

* Field "language": This field is required.

Video form errors:

* Field "youtube_url": Enter a valid URL.
* Field "language": This field is required.

How can I do in order to import correctly a text?


If you ever come across this error, just refresh the page and try it again and it will work fine. The issue is most likely that you were on the page, went to another page, then clicked “Back” to return to the Import page. This causes a few issues with the Resources, but refreshing the page will solve it.

Thank you very much for your great support. Now all the problems have been solved.

Hi. I have an import problem on Safari (Mac OS 10.7.2). Every time I try to import a lesson (English, with or without sound file), these error messages appear.

Script conversions form error:
Field “script”: This field is required.
Translations form error:
Field “language”: This field is required.
Lesson Notes form error:
Exercises form error:

I tried refreshing the page and saving it again, but it didn’t work. I deleted the failed import and did it over again to no avail. I logged out from LingQ, cleared the cache and cookies, and tried again, but it didn’t work either.

Then, I can’t import any new lessons for several months.I didn’t go to another page while I was on import page because I’ve read this could cause the error. When I try from another Mac, I can import lessons. It seems like my Mac did something wrong once, and LingQ server never forgot that malpractice.

Could you help me to solve this problem? I can’t borrow a PC every time I import lessons. I want to use my main PC.

Another user had reported a similar problem, saying that the imports from their own computer didn’t work but their work computer did.

Is the issue only in Safari or in all browsers on your computer?

I only use Safari on Mac, but another Mac works well with Safari when importing new lessons.
Firefox often crashed, so I deleted Firefox from my Mac.

For the sake of testing, can you try installing Google Chrome and seeing if the same issue appears? That will help in figuring out if it’s a browser issue or a computer issue.

Thank you for your help, Alex. I downloaded Chrome, and it worked. I will use Chrome when importing lessons.
I hope I can use Safari in the future.

OK, great. I’ll keep testing in Safari and see if I can figure out what might be causing this. If anyone has had similar problems in Safari, please let me know!

I am trying to import some vocabulary just for my own personal use. This is the message I receive:

Exercises form error:
Field “exercises”: This field is required.

I am using a MacBook Pro with Safari. I have never tried importing anything so it might be that I am doing something wrong. I tried refreshing the page.

Any suggestions will be appreciated.

Hi Marj,

Can you scroll down and select “Exercises” from the --Select Resource-- dropdown? Let me know if there is a language already selected. If so, try ticking the box next to it to delete it then saving the lesson.

I tried your suggestions and got the same error message.

Since I’m stubborn, I don’t give up too easily! I used my trusty little PC netbook (other than Mac, it’s the most dependable computer I’ve ever owned). I used Opera browser and checked to be sure that everything was checked or selected and that all the boxes had text in them. I even put the word “the” into the text box under the “Exercise” and “German” drop-downs. The import worked on my first try.

I then decided to give Mac another chance. I used Safari and did exactly the same thing I did with Opera on the netbook. It worked on Mac, too. Either this is my lucky day or I’m learning how to correctly import content.

Glad you got it sorted out!
I did check, and the Import does seem to be working correctly. If you run into any errors (aside from Category or Type not being selected), try starting again by clicking on “Import” again then repeating the process.


I’m using Firefox 14.01. I notice that when I import a lesson of my own, words that I have already marked as “known” (from previous lessons) appear to be blue as if I don’t know them. In other words, on a newly imported lesson, a great deal of words that should appear white without highlighting appear blue. This is not too big a problem, however, I feel that the issue is inflating my “known word” count, making it harder to keep track of my real progress. Is anyone else experiencing this? Any suggestions/insights are most appreciated.


@cdstreet - Thanks for reporting this. We haven’t noticed any issues with Known words not displaying properly. I wonder whether here the issue is with the conjugated form of some words, where you may have marked one form of the word as “Known” but another form is still considered New. Could you give us some examples of which words are giving you this issue?