Problem with keyboard shortcut in Sentence mode

Hello,

In sentence mode in the browser I always run into two problems:

The problems appear when I use the forward arrow on my keyboard to jump between LingQs. That works perfectly in normal reading mode.

However if you are in sentence mode there are two problems:

  1. if you press the arrow forward and the next LingQ consists of multiple words then only the first word of the LingQ consisting of multiple words gets selected. That should not be the case. Rather the complete LingQ should be selected (all the words in the LingQ together).

Additionally if you then press the arrow forward again you can’t jump to the next LingQ.

Then I always have to refresh the page in the browser, which happens every couple of minutes.

I get the impression that there exist no programming for the webpage that is made for this particular instance (jumping forward through forward arrow when next LingQ consists of multiple words). In normal reading mode I have never experienced this kind of problem. There you can simply press the forward arrow and the whole LingQ (multiple words) is being selected.

  1. if you have the last LingQ of the sentence in sentence mode selected and press the forward arrow then you obviously jump to the next sentence. When you are there you have to again press the forward arrow to arrive at the first LingQ of this sentence. However sometimes after pressing the arrow for this purpose the view just jumps to the next sentence although the current one had LingQs which should’ve been selected after that keyboard action.

Additionally I would suggest to give the user the possibility in the preferences to “show translation in sentence mode by default”.

Thank You !

2 Likes

Thanks, we will look into this.

1 Like