Problem splitting longer lessons

For the past 2 days I have been having a problem importing longer lessons. It worked earlier this week (the lesson would be split into (1) (2) etc.). Now I am only getting the first lessons and the rest is missing completely.

1 Like

I just tested this on my end, tried importing two ebooks and all parts were imported properly. Do you still have the same problem? Were you importing through “Import eBook” feature or by manually copy-pasting the text on the Import Lesson page?

Importing ebooks works fine (and is a great feature).

I was manually copy-pasting the text of a podcast on the Import Lesson page.

I just tried it again with a long text transcription of a podcast and the same thing happened. It created a (1) lesson, but nothing after (audio is about an hour long so I would anticipate it would be 3-4 lessons).


I have the same problem, I am importing Harry Potter to LingQ (manually), the first time was perfect but now is horrible, and seems that is getting worse, I have imported a chapter that the audio in the third part is missing.

@headspin @lorena.lingq Strange, can you look again now and let me know if additional parts appeared? I just tried importing manually longer text on my end and I’ve got all parts properly. Everything seems in order.

1 Like

The additional parts that I tried this morning have appeared now.


I just tried another longer lessons from the same podcast by copying and pasting the text and the same thing happened, only the (1) lessons is there. How did you make the rest appear last time for me?

I haven’t done anything. How long it’s been since you imported that lesson and only part 1 appeared? Can you check again now if other parts show up?

Just checked now. Still just part 1 and none of the rest. It’s been about 20 minutes now

@zoran It’s the next day and there is still only part 1. Seems to still be a problem.

Today I tried to import a French ebook on my laptop.

Attempt 1: Imported from a pdf file, lessons created ok but there was problems with the letter “f” so quite a few words where corrupted. Delete and retry…

Attempt 2: Imported from a textile. One big lesson with correct handling of “f” BUT it’s way to large (I use the mobile to read/listen while commuting): Stats: 86728Total Words|11054Unique Words

Can you please send me a link to Part 1 to support(at) Also let me know from where you copied the text from?