Popup: You have unsaved changes. Continue?

I’m getting this popup off and on when I click on blue words to create a LingQ; specifically, I’m getting it when I hover over the blue word and then click on the … button to launch the dictionary I’ve chosen. However, I don’t have any unsaved changes anywhere, so I’m not sure what it’s referring to. If it would help figure out what’s up, it’s currently happening for me while studying German, and I have my dictionary set to the PONS one (but it was doing it earlier when it was set to the default Babylon one, i.e. not a new popup window).

I reported this error some time ago, and it occurs daily - very annoying.

Only on Chrome, not with Firefox.
And please tell me that I should use Firefox, it’s so slow compared to Chrome…

Do you have any extensions installed in Chrome? I suppose it might be an extension causing problems (I kind of doubt it, though). And yes, I agree, Firefox has become ridiculously slow with each new update, so I’ve switched to Chrome almost 100%.

Hi guys,

Another user reported this same error here: Lingq Widget Problems - Language Forum @ LingQ

We are looking at the issue and hope to be able to fix it, but as Mark says in the above thread, it’s also possible that it’s browser related.

It must be within some browser specific Javascript code because it occurs in Chrome, never in Firefox. I cannot say anything about other browsers.

No error on Safari (Mac) either.

I’ve experienced the same error in Chrome.

@Mark: There are several problems with the new version of Chrome when I try to create my own LingQ. Everything worked fine with the older version.

  • Copy & paste from the dictionary is quite slow. It lasts a long time before I can highlight an explanation from the dictionary.
  • Adding tags is quite slow
  • It lasts very long when I click in the hint or the usage before the cursor is shown

I tried this with Chrome and Iron. Iron is a Chrome clone without the spy parts of Chrome. I tested it: The problem occurs in both browsers. Other browsers work fine. I installed an older version of Iron and everything worked fine again. The problem is definitely the new Chrome version.

@Vera - Yes, there are those problems. I have those issues too sometimes. We are trying to figure out what we can do there. Unfortunately, they seem to be Chrome bugs not ours. We’ll look for workarounds… :slight_smile: