Not getting reverse flashcard feature to work

I’d like to review each day’s lines two ways: the first with Italian that I have to respond to with the English and vice versa. When I try to get all the cards in English, I get about a third of them to come up that way and the rest still come up in Italian.

These are how my review settings look. What do I need to to differently?

Hi Cheska,
Everything seems to work properly on my end. As you’ve said, reverse flashcards should translation on the top, which should be in English in your case since English is your dictionary language. Check your reverse flashcards settings and make sure everything is set up properly there. Translation should be selected to show on the Front and Term and Phrase on the Back.
Also, are you sure you have correct English translation added for all of your saved LingQs?