Many things do not work properly

I did not use lingq for while - only forum - but now I try to work with the system and many things do not work properly.

1 I have recorded on my computer a mp3 titled who is she part 0 but I do not see one part 0 neither in french nor in russian.

2 I have lesson in Russian with 3 unknown words but the buttom to make them known does not exist I have to click each word - nice to me that they are only 3.

3 I work on 10 inches screen and popup window with number of known words etc tend to be fixed partly outside of my view to the right. I manage to get it fully visible by going back to start of the page but I have to do it again and again - and the problem is never solved

4 I try to copy the text of a lesson but when selected it deselect itself- then part of the text is not visible any more.

one more thing this double forum entry (because i click enter too soon) I use to click enter to go to the next line. Don’t you lol ?

  1. There are no “part 0” lessons in the system. That may be a name on the mp3 file but the mp3 file names do not necessarily reflect the lesson names and should not be used to find lessons. It would make sense, in this case, to go to Part 1 of Who is She which does exist.
  2. If you have already pressed the I know all button, you can’t press it again. If you then start highlighting words or phrases, this will increase your New Words number on the page. You will have to deal with these words individually.
  3. I’m sorry, there isn’t much we can do about the display problems you are having. We try to make our layout work under as many different screen resolutions as possible but, at some point, we have to sacrifice some compatibility to provide the best user experience for the majority of users who have larger screen resolutions.
  4. You can not copy and paste text on the lesson page because our functionality is not compatible with standard copy/pasting. If you want to copy/paste, open the print window.
  5. Hitting enter does not submit posts for me. What browser are you using?

i manage to copy and past another lesson

Enter does not lead to the same result each time - maybe my mouse pointed to the send button when I put enter but I doubt that and I doubt this is the origin of the problem - I am on firefox