Link in Lesson notes is messed up

I added a link to a Lesson note (Lesson Login - LingQ) because another lesson is related to this lesson.

The link is:

But the system changed it into:
and this link doesn’t work.

Do you have an idea why the link changes on the Lesson page? It looks perfect on the Import page.

The system shouldn’t change any URL. I think it may have to do with the fact that the text and the hyperlinked URL were not the same. Did you copy and paste the link from somewhere, by chance?

I did in fact copy&paste it from MS Word. The link in word is correct. I’ve checked it several times.
I always do it this way but I’ve never checked the links. Now I did this and I figured out that it went always wrong if I link to another lesson on LingQ. If I add a link to an external page everything works.

The reason I ask is that I copied and pasted the link you posted on this forum and it appeared properly, including the linking URL. Does this happen every time you copy and paste this link from anywhere or just from MS Word?

The links on the forum are fine. It only happens in the Lesson notes, which links to LingQ lessons. Links to other websites work. Have a look at this lesson for an “external” link: Login - LingQ These links are OK
For another “internal” link have a look here: Login - LingQ This link doesn’t work.
I always use MS Word to prepare the Lessons notes.

Ah, I think I know what’s happening. When you save it initially, it works properly, but if you go back in and edit it then save it again it converts the URL for some reason. We’ll work on getting this fixed. Thanks for the report!

Great that you could figure out the problem! Let me know when you’ve fixed it.

Hi Alex, anything new about this issue? I would like to add more notes but I don’t want to do this twice!

Ah, sorry for the delay on this. It should now be fixed!

Hi Alex.

I’m Sorry, it still doesn’t work.

I want to add the following text to the lesson:

Hier ist der Link zur entsprechenden Lektion in Form eines Dialogs in der Sammlung " Ab jetzt lerne ich Deutsch! Privat!"
Here is a link to a matching lesson, this time in the form of a dialogue, from the Collection “Ab jetzt lerne ich Deutsch! Privat!”

The result is that the system want to open to the page
The result is “Oops! It seems that you have no access…”

P.S. I’ve refreshed the page several times. I’ve used FF.

Very strange… We will be sure to take another look at this. In the meantime, are you able to use link shorteners (such as to display the URLs?

I’ll wait for the fix. I for example would trust links more that lead obviously to another LingQ page than a short URL.

Anything new?

A fix for this will be included with the next update, allowing you to hyperlink text the same way you can in the Bio section on the Settings page.