LingQ Importer extension imports wrong subtitles

I use the LingQ Importer extension (chrome) to import youtube videos with subtitles. Unfortunately - if youtube provides a variety of subtitles - it does not import the subtitles that I have chosen (but other subtitles). Is there a possibility to determine which subtitles will be imported? It is a pity, a show that I like has added additional subtitles and now the LingQ Importer extension imports subtitles I do not like. Is there a solution to this problem?

Odd. Did you play the video for a few seconds to see the subtitles come up in the language you want? If not, try importing AFTER you see at least some of the subtitles. What’s the video? A link to the video and which language you are trying for might help the LingQ team.

If that still doesn’t work, you could grab the transcript and import it “manually”. If you go to the area where you like/dislike/share/save…to the right there should be 3 dots. Click that. That will give you the option to “show transcript”. The transcript will pop up in the upper right. There’s a dropdown here where you specify which transcript you want to follow. Choose the appropriate language you want.

1 Like

Thank you for your answer, Eric. The manual import works. But if I import the following video with the LingQ importer extension (chrome), there is a problem: PBS NewsHour full episode, May 11, 2022 - YouTube. There are three English subtitles. I chose the third which is the best. But the LingQ importer always imports the first one (English - CC1, only capital letters).

Ahh tricky. It must just take the first “english” subtitle that isn’t “auto-generated”. In theory you could import via the extension and then replace the text with the transcript you actually want. That’s what I used to do in a semi similar situation, however, in LingQ I’ve not found an easy way to do this with the new editor.

You could, do the manual import of text as I suggested and then edit the lesson and add the link to the video, and/or extract the audio file via a youtube to mp3 conversion and upload that audio. Then you can “regenerate lesson” and/or generate timestamps to match the audio to the sentences. I’m going a little bit from memory here so you might have to tinker.

At least until there’s an answer from LingQ team. Maybe there’s another way.

1 Like

At the moment it’s not possible to choose what subtitles to import if there’s more than one option available for the same language. For most of the videos you won’t have that problem.

1 Like

Thank you for your answer. It would be nice if this little problem could be fixed in the future.

Hi Matthias_576. I have a bit of a workaround for you…

You can do the normal import. This will pull in the wrong subtitles in your specific situation, but we can edit these…

Import the video like you normally do. Go to “Edit Lesson”, then click “Regenerate Lesson” button on the left hand side. This will make the text fully editable. You can then grab the specific subtitle text from Youtube via the 3 dots as I described in my other post and pasted these. Clicking “View Lesson” should save and you should see the new subtitles.

HOWEVER, I tried the above for a particular lesson I imported and it was showing a mismatch for awhile between edit lesson view and reader view. It ultimately switched back to the old text in both (next day). Soooo…

If you have this problem. Go to “Edit Lesson”, Click “Regenerate Lesson”, delete all the text. Leave a singe word, or letter (in case it might complain if there’s no text at all). Click “View Lesson” which will also save the lesson. Now in “Reader View” you should see the one word. Now go back to “Edit Lesson”, Click “Regenerate Lesson”, and paste the transcript for the subtitles you want. Then click “View Lesson” which should save. Now in Reader View you should see your chosen transcript.

I’m not sure why the first overlay didn’t work for me. It may be because the text is virtually the same except for capitalization or punctuation. If so, you’ll probably run into the same issue, but the work around of clearing the text and saving appears to have resolved that.

1 Like

Thanks a lot! I will try that.