Light up your brain - without sound - Is anyone else experiencing

I have problems and cannot hear the sound.
Perhaps others have the same.

Yes I have the same problem. I wanted to listen to the story of whitesnow, and there isn’t any sound or recording.

I have no problem. This sound file is on an external URL. You may have to adjust the volume on your computer, or the connection to the external sound source may be temporarily unavailable. Please check the volume and try again later.

Can you hear the sound if you use the flash audio player on the site? If you click on the “Download Audio” link, you do have to wait a while for the sound to start. If you want to download the file, you have to right click on the Download Audio link and “Save target as”.

Steve - the volume isn’t the problem it is ok.

Mark - if I click on the “download Audio” there is nothing working, no reaction! - in this way I have no possibility to save target as…

Irene,

You have to right click using the right button on your mouse. Also, can you hear the sound when you use the player on the page at the bottom of the LingQ widget?

That was me!

It looks like this is a bug in Internet Explorer with audio that uses an external URL and is not hosted on our server. We will look into fixing it but in the meantime you should be able to download the file by right clicking and clicking “Save target as…” or whatever it is in your language. Or, of course, you can use Firefox.

I can also reproduce this problem.
It can’t be a general problem with externel URLs because I’ve done some import with externel URL’s and it works good.
The download works.

“PETIE’S PEANUT BUTTER PIZZA”:
I got no sound for this item, and, additionally, when trying to download mp3 file, an error occurs:

Forbidden

You don’t have permission to access /empeestrs/PetiesPeanutButterPizza.mp3 on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8b mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at lightupyourbrain.com Port 80

I think they have something overengineered with Apache’s settings, I easily can get to the proper directory
(http://lightupyourbrain.com/empeestrs/),
but when I click on “PetiesPeanutButterPi…” link - I get a “Forbidden” message.

For the item “THE STORY OF SNOW WHITE” - it has also no sound with on-site embedded mp3 player, though it allows to download separately.

my browser is Google Chrome.

When I try to open THE STORY OF SNOW WHITE, browser does the following:

127.0.0.1 - - [25/Sep/2008:11:19:52 +0400] “GET http://www.lingq.com/learn/en/workdesk/256593/ HTTP/1.1” 200 95127
127.0.0.1 - - [25/Sep/2008:11:20:13 +0400] “GET http://www.google-analytics.com/ga.js HTTP/1.1” 304 -
127.0.0.1 - - [25/Sep/2008:11:20:28 +0400] “GET http://www.google-analytics.com/__utm.gif?utmwv=4.3&utmn=396664922&utmhn=www.lingq.com&utmcs=UTF-8&utmsr=1280x1024&utmsc=32-bit&utmul=ru-ru&utmje=1&utmfl=9.0%20%20r28&utmdt=Workdesk%20-%20LingQ&utmhid=1566425167&utmr=0&utmp=/learn/en/workdesk/256593/&utmac=UA-197344-4&utmcc=__utma%3D206362254.513596275677900200.1220455420.1222322013.1222325002.81%3B%2B__utmz%3D206362254.1220455420.1.1.utmcsr%3D(direct)|utmccn%3D(direct)|utmcmd%3D(none)%3B HTTP/1.1” 200 35
127.0.0.1 - - [25/Sep/2008:11:20:35 +0400] “POST http://safebrowsing.clients.google.com/safebrowsing/downloads?client=googlechrome&appver=1.0&pver=2.1&wrkey=AKEgNiu8wvUe3WgT2ucqHNzt7ETnuBuoBQBmDkK-MKhszbq6LO-Z7i8S3HFwicGMcQPolYPqjkiePqzslRWWMJKE9RITBag2xw== HTTP/1.1” 200 671
127.0.0.1 - - [25/Sep/2008:11:20:44 +0400] “GET http://www.lingq.com/learn/en/workdesk/256593/related/ HTTP/1.1” 200 2
127.0.0.1 - - [25/Sep/2008:11:20:53 +0400] “GET http://static.cache.l.google.com/safebrowsing/rd/goog-malware-shavar_s_6871-6875:6871-6873 HTTP/1.1” 200 5201
127.0.0.1 - - [25/Sep/2008:11:20:57 +0400] “GET http://www.lingq.com/media/_10/reader/lingq-button-hover.jpg HTTP/1.1” 200 1959
127.0.0.1 - - [25/Sep/2008:11:21:01 +0400] “GET http://lightupyourbrain.com/empeestrs/SnowWhite.mp3 HTTP/1.1” 403 522

I guess the last line shows that getting mp3 file from http://lightupyourbrain.com is forbidden (403=forbidden) to us. Some kind of anti-leecher may be working.

…but Firefox does really work!

I think they at http://lightupyourbrain.com/ imply some restriction on what browsers are allowed to access their content. I think they analyze http-headers for that

Sorry for a bit more technical info.
I tried to analyze this in some more detail.
my sniffer tool shows me - this problem occurs when “Referer: http://www.lingq.com/…” header is present in a query.

  • Firefox browser does not send this header - so it works with lightupyourbrain.com website.
  • Google chrome sends this header - so it doesn’t work.
  • I couldn’t check up how’s Internet Explorer doing.

So I can conclude that lightupyourbrain.com website doesn’t like when someone leeches it’s mp3 files, that’s a problem.

Firefox just doesn’t show that you come from lingq.com (kinda cheating) - so it works :slight_smile:

Thanks, Pavel. I’ll forward this to our technical guys.

Maybe they don’t want that items are shared?
Does we have the allowance to import and share items from lightupyourbrain?