Lessons not working on mobile

For about three days I’ve been doing the same two lessons over and over again (once a day maybe, to try if a different internet provider would make a difference). In the end of the lesson, it says that I finished it successfully:

But then upon going to the main page, the lessons look like so (first one is the exact one I tried doing to take these screenshots):

Upon opening the lessons anew, the words are highlighted as they originally were. Although my own meaning pops up when I click on a blue word to (re-)make a LingQ, the word is highlighted blue, and even after I create the LingQ again, it doesn’t show in my list of LingQs.

Aside from my self-written meanings of the words, there’s no other record of me ever having done the lesson - my streak is zeroed, no new LingQs have been created, no new time listened added.

I use an Android device, the app was last updated around 2-3 weeks ago.

PS: Additionally, I couldn’t log into the forum to report the issue from my mobile device. It told me to contact the owner of the forum with regards to my account. On PC, all is fine.

Thanks for reporting the issue. Have you tried to logout/login back into the app?

Tried it, no change.

Please try reinstalling the app and let me know if you see any difference.