iPad. Internal error

Hi, I’m trying to update lingqs on existing lessons on the iPad in Russian. They seem to update ( eg from 1 to 3) but when I leave the lesson I get an " internal error" message and when I go back to the lesson the links have reverted to previous values. This is only an issue since the update.

Update: it’s also happening on Safari on my desktop mac…

I tried this, but didn’t seem to be having the same issue. Is this for all lessons you try? Also, can you try creating a new LingQ in one of the lessons and update that, then see if it works properly?

Creating new lingqs seems to be fine but editing any of my existing ones seems to be impossible. I lose any changes as soon as I try to leave the lesson. I’ve tried on an ipad, and on both Firefox and Safari on a desktop Mac with the same result.

And, yes, this has happened with four different lessons, some self-created, some taken from the library

Also, any newly created lingqs have the same problem.

Can you try clearing your cache/cookies or refreshing the page when you receive this error? We have made some small changes that should hopefully have fixed it, but be sure to let us know if the issue is still there.

Nope, still same problem, I’m afraid. Cleared cache and cookies. I’ve just tried it in my spanish account (which I never really use normally) and exactly the same issue. The error is something like Internal Error [object object] and a red cross.

OK, we are continuing to look into this one.

So it appears that you are reporting two errors:
(1) You update the status on some LingQs while viewing a lesson, then when you leave the page you get an error and when you return the statuses aren’t updated.
(2) You are unable to edit previously saved words, regardless of when they were saved.

We need some more information from you to figure out what’s causing this error:
For the first one, where is it that you are changing the status? Are you doing so on the yellow popups or are you opening the LingQs, clicking a different status and clicking “Save”? When you leave the page, do you get the error regardless of what page you go to?

For the second, what exactly happens when trying to edit these LingQs? Can you take a screenshot to give us a clearer picture?

OK, this problem only seems to exist on computers and wifi in my office. Works fine at home and on public wifi. Maybe some issue at my end. I’ll leave it until after christmas and see if it clears up.

Thanks for the heads up. Let us know how this goes!

Thanks for your help and patience. I’ll perhaps come back to you in the new year if it remains an issue.