Internal Server Error

https://www.lingq.com/forum/69/36939/

This post is awaiting moderation.

P.S.
Now I can see the post. I wonder if the error was only temporary although this phenomenon has been happening several times.
Does that response from the server happen by some coding mistakes or a slow internet connection?

“This thread is currently pending approval. You will not be able to reply it until it has been approved.”
I couldn’t approve the thread. The server responses with the message “Internal Server Error”.

https://www.lingq.com/forum/69/37065/
“Please correct the following error:
This thread is currently pending approval. You will not be able to reply it until it has been approved.”

The same happens to me when I try to approve threads. It looks like the server gets my approve but cannot process it completely. So, the thread looks like awaiting for moderation but does not accept moderator’s actions.

1 Like

If you approve a thread, you can eventually post comments after a while. But why should the response from the server take such a long time? Are they doing double-checking or something?

Either that or perhaps a thread is only completely approved by the system until at least three moderators have got frustrated while trying to approve a post (and, in some case, give a speedy reply). I notice that sometimes the same post appears three times the minute I click ‘approve’.

I suppose some sorts of script-eating worms or what are usually called programming bugs are enjoying their lives, having settled in for good on the hard disks of the LingQ server.

They appear 3 times on approving a message.
While approving a thread we can see the Internal Server Error.

Yes.

Dictation is not working

1 Like

I have the same problem.
I’ve tried with chrome and internet explorer.

This issue was fixed.

I’m very sorry everyone. This thread seems to have been missed. We will look into this right away.

Approving threads does have a cache issue which allows moderators to approve posts, but it does take awhile to approve. If you try to approve a thread twice, an error message will appear.
We are working to improve this and we appreciate your patience.

Still the same issue still exists.

A message was shown that the thread was approved. But it still has the Approve/Reject links. Trying to approve it again I receive the Internal Server Error.

@Ress, you did approve that post but the system takes a bit of time to show it as approved. If you’ve already clicked “approve” once the “Approve” button will still be showing but the process has already started.

Well, but let it be without such kind of errors.

By the way, I can see a thread marked as it waits for moderation. But I cannot find the message which needs an action.
https://www.lingq.com/forum/3/8297/
Any suggestions?

The delay is something we’re going to work on.

I’ve also tried looking for that message but can’t find it. I’ve informed the developers this morning. Thanks for letting me know!

“Internal Server Error”
https://www.lingq.com/forum/5/37162/approve/

I am having the same problem, as always.