Importing Vocab with a .CSV

I saved a file of about 50 words as a .csv that I want to import, with column 1 being the word, 2 the definition and 3 a phrase. If I try and import it, it just gets stuck on the importing screen indefinitely. What should I be doing differently?

see this old thread

It’s 3 years old, and LingQ wasn’t able to fix/to improve the import since that time. But now we have gamification and avatars… IT’S A PITY…

I haven’t been able to get the csv import to work. I am fairly new here. Perhaps others have better advice. Try asking Vera or Alex in Support.

@CapslockEngaged - Would you be able to send this .csv file to support (at) so we can take a closer look and see what might be causing problems here?


Welcome to LingQ.

  • For me option 2, Import by pasting a list of terms, always works better than option 3, import a csv file. But that option is not working for me today.

  • For the record, I’m using Linux Mint 17. I tried option 2 with both Chrome Version 36.0.1985.125 and Firefox 30.0 Mozila Firefox for Linux Mint mint [sic] - 1.0. I also tried typing the text in Linux’s plain vanilla text editor Pluma. Nothing worked.

  • For sure, no matter what operating system or text editor you use, the vocabulary import function does NOT work with smart quotes, in my experience. Also in my experience, a file that has been exported as a .csv file from Excel will not work. Though I think other members have had success with such a .csv file.

  • With a little effort, you can create a csv file by hand using a text editor that handles tables. Make sure your sample sentence has no commas in it, otherwise you will create a spaghetti nightmare. Paste your tab-separated or comma-separated data into the text editor. Convert the text into a three-column table separating the columns on the comma or the tab. Add columns to the left and right of the table and between the columns. Copy-paste a quotation mark into all the rows of the column on the far left and the column on the far right, and copy paste this “,” into the other two columns.

  • The smaller the Csv file, the better.

  • *** Sometime if you get the spinning wheel of death forever while importing, a check of your vocabulary will show that some or even all of your terms got imported.

  • Sometimes, like today apparently, nothing works.

@alex I ended up just opening the CSV in notepad, copy pasting the text as an imported lesson, and LingQ’ing everything from there. It was only about 50 words so it didn’t take long

@donhamiltontx When I want to paste a list of terms, what separates the terms, hints, and phrases? I’ve figured out that hitting enter creates new LingQ’s, but do I have to go to each individual card by hand later and fill it in?

@CapslockEngaged “what separates the terms, hints, and phrases?”

If I follow you correctly, you mean when you use Option 2. Pasting a comma-delimited text into the import area usually results in a properly sequenced item in Vocabulary. But in my tests today, all three items ended up in the terms field. That should not happen.

On the chance that you are talking about creating LingQs while reading a lesson, then pressing enter on a blue new word will (should) automatically create an item with the term, definition (the first definition showing in the dashboard on the right, if there is one), and the sentence (or part of the sentence) as the example.

@CapslockEngaged - OK, glad you found a workaround!

@donhamiltontx - Thanks for the heads up on this. The .csv import feature isn’t widely used so we don’t get much feedback on it. I didn’t realize there were still some issues with this, so I’ve passed this along and we’ll see what we can do to improve things.

@donhamiltontx Yes I mean the second option, and I also had comma separated values all go into the term field (and nothing in the phrase or hints).

Everything going into one field was unexpected behavior.
You can edit your terms by going to Learn > Vocabulary and copying and pasting hints into the hints field and the sentence into the sentence field. A pain, but better than entering all that by hand.

You have inspired me to try importing with csv files again. I got discouraged on earlier attempts. (spinning, waiting, hoping, reboot, try again …)