Imported Audio

I decided to try to import some material for the first time and I came across a problem. It seems my audio file won’t play within LingQ’s player (it buffers and displays that it is 0 seconds long. According to the help documentation (Import Help) it requires that the audio file needs to be a mp3 saved at 64 Kbps and 11025, 22050 or 44100 Hz. I rendered and uploaded my mp3 with these specification: Size: 206.4 KB, Length: 0:26, Bit rate: 64000 kb/s, Sample rate: 22050 Hz.

Am I missing something here?

Hi Luke,

Did you upload a file with the same name in another lesson? I ask this because I tried reexporting the file with different bit rates but was unsuccessful. I have a feeling the audio was uploaded in two different places on the same day, so Amazon S3 (our storage provider) might be a little confused when trying to access two seemingly identical files.

In any case, I’ve reexported it with the name “about3” and it appears to be working properly. :slight_smile:

The first time I rendered it as 96kbps and 44100 Hz with the file name ‘about’. After reading the documentation, I rendered another with the format stated above and named it about2 (a different name).

When I look at your fix, the file that is there now looks to be my first render (Size: 414.7 KB, Length: 0:26, Bit rate: 128000 kb/s, Sample rate: 44100 Hz). Maybe when I removed it, saved, and tried to upload another something happened inbetween? I could have also checked the “Remove uploaded audio” box and uploaded the new audio all in one go which may have caused the problem.

Thanks for the help!

It’s fine to upload the initial audio file. We try to keep files smaller so it’s quicker for users to download them, there’s no harm done in 96 or 128kbps :slight_smile:
Just make sure that you select “Constant bit rate” as that option works best on the site.

Hey Alex, sorry to bother you again but the same issue happened once again. I filled everything out, uploaded the audio with the correct format and saved. First it showed Na:Na (or something of the form) which I believe means, from reading other user issues, that there is something wrong with the file so I removed it, saved and re-uploaded it using a different file name. It is now showing the audio is 0:00 out of 0:00 seconds long again. Link below:

Thanks in advance.

It’s unfortunate you keep experiencing this error.

What program are you using to record/export this audio file? Can you render it as 44100 Hz and try it again?

Hey Alex. I tried to upload a 44100 Hz version but still the same results as last time. I’ve been using Camtasia Studio (it’s meant for screencasting and the likes, but also has an audio section that allows you to render an mp3 in many different formats).

OK. I’ll keep looking into this to see what the problem might be. Could you also try recording and/or exporting the audio file with Audacity and see if that helps?

So it seems the problem might be cause by the files rendered by Camtasia? I just used Audacity and everything rendered fine. Camtasia isn’t rendering ‘poorly’, it’s just Camtasia’s rendered product and LingQ are not currently setup to work correctly. What does LingQ use to deliver audio? Actually, I’ve been interested on what kind of platform LingQ is run on (a CMS system of some sort)?

@Lukecast - LingQ is written on Django/Python. It is certainly not a CMS system.