Import: Private lesson, tracking listening time, ?a bug?, and a work-around

Hello – Here is what I am trying to do, the problem(s) I’ve encountered, and what I’ve done to fix it.

I am importing my own lesson materials from a variety of sources – books, audiobooks, podcasts, etc. These do not meet the criteria for sharing, so they are marked private.

The issue I have is two-fold:

  1. It makes no sense for me to upload the audio just so I can download it.
  2. It makes no sense to waste LingQ server space uploading private audio files.

However, without uploading audio, one does not get a button to click to give credit for listening. Yes, I can go to Community → Hours of Listening → click on “+” and manually enter the time every time I listen. But an automatic increment of the correct time is much handier.

I tried going into the Import / “Advanced” settings to give a URL for the audio (I share it to myself using Orb, or in the event of a podcast, the URL of the podcast audio). However this has elicited a 500 server error every time I try to save.

What I ended up doing was uploading a short, irrelevant “dummy” MP3 to the lesson. This causes the lesson to display the listening ‘counter’ gadget. But the time credited when I click on it now matches the “dummy” mp3 I have uploaded, not the actual time of the audio corresponding to the lesson.

To fix this, I go back to the lesson as listed under Import and select the Advanced options. There I enter the actual number of seconds I wish to credit myself for each listen, and then save.

Now, I can easily increment my listen count with a correct time increase logged to my Progress Snapshot.

If there is an easier way of doing this, I’d much appreciate the info.

All the best – Paul

Hi Paul,

I’m sorry about the bug with the external url in the Advanced Settings. We will get to it in the next few days. However, even if when it is working you will have to enter the time of the audio file in seconds for the counter to work. We can only figure out the duration automatically for sound files that are loaded onto our server.

Having said that, for your purposes, I agree, it makes more sense not to upload the audio to our server just for your own use.

Thanks for the quick reply. Yes, I had assumed that the URL method also required a time input. My goal was to find a way to give myself the ‘listening’ gadget without having to upload the audio. Using a URL would require no upload so I look forward to the upcoming fix - however the ‘dummy file’ method works fine also, and only takes up a few K of server space.

Another possible approach might be an advanced option to ‘add listen count tool’ for private lessons lacking shared audio.