Import not working bug

Whenever I try to make a new import and press “Save and generate lesson” It just loads for a split second and then nothing happens. There is no error message or anything, the lesson just never saves and when I exit the lesson is nowhere to be found. It worked perfectly when I imported my first 5 or so lessons today but now it just doesn’t seem to work.

Has anyone else encountered this issue and managed to find a workaround for it? I’ve thought about using the app on my phone but it would make the whole process unnecessarily more tedious, especially considering that I plan on importing over 100 lessons.

I saw that another person had the same issue 3 months ago but nothing seemed to come out of it.

I hope we can find a solution for this soon,


Sorry to hear that. Do you still have issues? Does it only happens when you try to import a lesson manually? Do you have the same problem with anything you try to import?

It’s actually when I try to import a lesson manually that contains an audio file. When I try to “select file” for audio nothing happens, the file doesnt pop up or anything so I instead used the audio URL to upload the audio (the files are MP3 and I’ve tried with different ones). And that’s when I instead get the “Save and generate lesson” bug.

I occasionally get weird behavior after importing several files. Sometimes, it’s my own impatience. It takes awhile for things to happen. I don’t do audio files at all, but they are probably fairly large and take time to process at the server.

Also, sometimes I can clear up unexpected behavior by reloading the site. You might also try another browser to see if the behavior is the same.

Just tried again (1 day later) and it still didn’t work :confused: I’ve tried reloading and changing browsers. Thanks for your input though!

1 Like

Strange, I am unable to reproduce the issue on my end. Can you please send the file you are trying to import to support(at)

I found the issue, its when the audio file is larger than 60 MB that it doesn’t work. With files smaller than 60 MB it works perfectly fine so I just had to compress the larger ones. Also when I use the audio URL instead of attaching the files directly from my downloads it never works, no matter the size of the audio file.
Thanks for your help.

Ahh, I didn’t realize your files are that big. Sorry, I should have asked.
Yes, the limit is 60MB and files larger than that can’t be imported.