I cannot enter a LingQ from the vocabulary page

When I enter a new word on the vacabulary page the screen justs reverts to page 1 of the LingQ lists without opening the screen to enter the hint and the phrase. The word is not added.

Hi Bill,

I just attempted to do this and it worked properly. We’re currently working on getting these LingQ-related issues sorted out. Are you still having the same issue?

I am also not able to create a LingQ directly on the vocab page.
The screen reverts to page 1 of the LingQ lists.
In fact, the item has been created in the background, but hint and example are empty.
Please fix this ASAP.

:-((

If I understand correctly, then this has always been the case. Refresh the page and both should appear as normal.

No, no, no! This has NOT always been the case!!
Only today and yesterday (?).
I just emptied my cache and refreshed the page.

The error still exists!

Regarding the order of LingQs, if you sort by “Creation Date” then create LingQs it should work fine. We’ll work on getting the other stuff sorted out.

I have just checked and the error is still there. As Hape says, this is a completely new error which has occurred during the last couple of days!

I think this error may be related to the missing hint error. Let’s see if it isn’t resolved at the same time. We are looking into it.

I have discovered a partial cure. For some reason my computer started to block pop-ups from LingQ. When I sorted this the screen appeared to allow me to enter hints etc. for NEW LingQs only. If, however, I enter a word that I have previously LingQd the pop-up screen does not appear. This makes it impossible to modify existing LingQs.

Thanks for reporting this Bill. We will get through this latest spate of problems. Please bear with us and sorry for the inconvenience.

I have done some more digging into this problem. It appears to be only LingQs at at status 4 where the popup screen is not opened. I tried some existing LingQs at status 1 and the popups appeared correctly. This problem occurs when entering LingQs through the vocabulary page when I am doing offline reading. I do this a lot.
It is very important that status 4 LingQs also open because either:-

  1. I have forgotten that I had previously LingQed it and need to be reminded of the meaning of the word. I often manually change the status of such words to 2 or 3 to put it back into the learning cycle.

  2. I have not forgotten the word but want to add to, or change, the hint. This is also quite common.

It is a considerable degradation of the usefulness of the LingQ procedures not to open status 4 LingQs from the vocabulary page and I hope that you can rectify this problem as soon as possible.

Ahh… I see. So, when you are trying to add a term that you have previously LingQed, it isn’t added. We will see if we can’t have some kind of notification, at least, that the term is already there. Then you can search for it and open it. Ideally, the existing LingQ will open up but that may be more difficult. We will get back to you.

I can see all LingQs (that exist) by entering them manually on the vocab page with one exception: if the vocab item contains an apostrophe.

I have already reported this bug here: http://bit.ly/hNTi94

Another idea:
Did you clear your browser’s cache? There were so many changes in the system within the last days, so the javascript code libraries may be not up-to-date. By clearing the cache, you can force the browser to fetch them from the server.

Hi Mark
It is only existing LingQs at status 4 that don’t open up. Existing ones at status1,2 or 3 do open so I don’t think it should be a big problem to make status 4s open as well

@ hape - I am not having a problem searching for LingQs containing apostrophes. Is this still a problem?

Hi Mark
Can I add that ALL LingQs opened up from the vocabulary page until a few days ago.

@mark

If I ADD on the vocab page an item with apostrophe that EXISTS, the existing item will NOT show up. Other existing vocab items WITHOUT apostrophe do.

E.g.

(1)
“l’abonnement” EXISTS (has an apostrophe in it)
On the vocab page I ADD “l’abonnement”
Result:
Page reloads, the existing LingQ does NOT show up.

(2)
“abandonnée” EXISTS (has NO apostrophe in it)
On the vocab page I ADD “abandonnée”
Result:
The existing LingQ shows up.

Hape,

I added “l’an” and “an”. They both appeared. Then I added “l’abonnement”. No problem.

If ti does not appear for you, why is that a problem? Just add “abonnement” without the “l’”. How big a problem is this? How much time do you think we should spend on this one problem that does not bother anyone else?

@hape - I, too, have no problem adding l’abonnement and searching for it or adding it again and having it open up. If it is causing you problems, have you tried deleting it and adding it again?

I should add that everything on the Vocabulary page should be working properly now. Including the opening of status 4 LingQs when you try to add them to your list again.