Having Trouble with Audio Button

For some reason in the past couple months my audio button (the silver and blue speaker button with sound waves coming from it) has not functioned at all. I press it and nothing happens. Does anyone have a fix for this? It worked a couple of months ago perfectly. This is with Japanese, but I believe it carries over to my other languages as well.


@justinkn - Often these issues seem to be browser specific. Which browser are you currently using? Would you be able to try another browser to see if the same issue persists?

Yes, I’ve just tried Firefox and it works fine! On Safari it does not work. Any tips on making safari functional?

@justinkn - OK, that helps :slight_smile:

May I know which operating system you are using and which version of Safari you have? I am using OSX Mavericks with Safari v7.0 and it seems to be working properly.

What you also may want to try is updating your flash player if it isn’t up to date: http://get.adobe.com/flashplayer/. Since the text-to-speech uses Flash, the issue may lie there as well.

FWIW, Alex,

On my MacBook Pro OS X Version 10.8.5:

  • Firefox 25.0.1
    Flashcards do not play, audio player for lessons does not appear.

  • Safari Version 6.1 (8537.71)
    No sound from the flashcards, whether I open them from the lesson or from the Vocabulary Section.
    Audio player for the lesson works.

  • Google Chrome Version 31.0.1650.57
    Flashcard sound works, and audio player appears and works.

I tested these both with Spanish lessons and Norwegian lessons.

@donhamiltontx - Do you have any add-ons/extensions in Firefox? It’s strange that the audio player doesn’t appear so I wonder if it’s due to a specific add-on.

For Safari, would you be able to open up the error console to see if any errors appear when you click on the text-to-speech icon? You may have to enable the Develop menu by going to Preferences > Advanced > “Show Develop menu in menu bar”.

@Alex re Firefox extensions and add-ons and the Safari error console:

First, now that I know the sounds function fine in Chrome, this bug is not a big priority for me.

FWIW, iTunes is my default mp3 player.


I disabled all add-ons and extensions.
The audio player still does not come up, but where it would normally be it says “Download File.” Clicking on that downloads the audio file.


I installed the latest Flash Player in Safari.

  1. In the lesson, clicking on LingQs in the right panel brings up a flashcard. Clicking on the audio icon gives the following message:

[Log] SMSound.play(): “sound_flashcard” is starting to play (soundmanager2.js, line 1144)
[Error] TypeError: ‘undefined’ is not a function (evaluating ‘_flash._setVolume(_t.id, (_s.muted && !_t.muted) || _t.muted?0:nVol)’)

  1. In the vocabulary section. Clicking on a single word brings up its card, and clicking the sound icon on the card gives

[Log] SMSound.play(): “sound_widget” already playing (multi-shot) (soundmanager2.js, line 1142)
[Log] SMSound.play(): “sound_widget” (soundmanager2.js, line 1144)
[Log] SMSound.play(): “sound_widget” is starting to play (soundmanager2.js, line 1144)
[Error] TypeError: ‘undefined’ is not a function (evaluating ‘_flash._setVolume(_t.id, (_s.muted && !_t.muted) || _t.muted?0:nVol)’)

  1. Opening Flashcards in Vocabulary and clicking on the audio icon gives this:

[Error] TypeError: ‘undefined’ is not a function (evaluating ‘_flash._createSound’) soundmanager2.js, line 456

@donhamiltontx - Thanks for the additional information. We’ll look at getting the Safari issue resolved soon. Regarding Firefox, we had some reports of this about a year ago but nothing since then. How long has this been an issue for you?

@Alex “How long has this been an issue for you?”

I wish I could give you a precise answer, Alex, but I can’t. For the past several months I have been studying imported Latin lessons with no audio. Only from time to time did I open up a French or Spanish lesson with audio. Whenever I started to try the audio, I remembered or thought I remembered seeing that audio did not work with Firefox. So my answer to your question must be a few months: I think.

Sorry, Alex, I did not realize I logged in as Metellus Cassius. Anyways, his answer works for me, too.

@donhamiltontx - No problem, thanks for the additional info! I’ll add this one to our list and we’ll take a closer look when we have a chance.