Google translate window not working

Hi guys, so i was reading a little and suddenly the translator stopped working. Whenever i click on a unknown word, it gives me the “oops, To continue creating unlimited LingQs, you will need to upgrade.” error message.

I don’t have any lingqs, and i’m not selecting any created lingq either, it’s just a aunknown word. If a highlight a phrase, the same error appears.

I’ve deleted my cache and right now i’m on a different computer and i still have the same error!

Any ideas? My studying hours aren’t over yet but this is killing me lol XD

Hi @bagashu - it seems that you have already reached your limit for 20 LingQs. Please note that it is a hard limit. Once you reach it, you will not able to interact with words anymore, even if you delete your previously saved LingQs. You may want to try our basic Premium membership ($10 per month). You can stop it at any time if you don’t like it.

oh! Damn! Didn’t knew that!

Thanks for clarifying it! Maybe i’ll give it a try and see how it goes!