External audio file

For test purposes, I’m trying to import a lesson with an external audio file, but I get this message:

“Please correct the following error: Field “external_audio”: Enter a valid URL.”

What would a valid URL be? This is the one I’m trying to insert:

I go to advanced settings and paste it in the Audio URL field, but when I save I get the error message.
What am I doing wrong?


I just tried this and it seemed to work properly. Be sure to enter a time in seconds as well!

I understand now what happened: I had a space at the beginning of the URL. Thanks!

Now I have a new problem: isn’t it possible to reedit the text we entered? I can edit the description and the title, but when I try to edit or delete the text or parts of it, it takes me back to the lesson. Weird…

Do you mean editing the lesson text? Sure, you should be able to edit it. Just click on the edit icon when viewing the lesson, then click within the main Text area and change the text, then click Save. Note that if you don’t have a text field selected and you press “Delete” then it brings you back to the previous page, but this is a feature of the browser.

Also note that if you have hit your private import limit as a Free user, you will be unable to edit the text in your lessons. Restrictions like these are removed when upgrading to Basic or beyond.

Alex, Fernanda is creating content for the Portuguese library, and as such these lessons will not count against her limit, if I am not mistaken.

Hi Alex
I did all that previously. I even cleaned the cache as you told me once with another problem. I still can’t edit. I have no idea if I have hit my private import limit as a Free user. (what is the limit?) I think this is the only lesson I have as private, because for the moment it is just a test.
As Steve says, I’m creating content for the European Portuguese library.

@mfr - Can you please tell us what happens when you follow the following steps: 1. Go to the Imports section, find the lesson you want to edit and click on the Edit lesson option in the lesson dropdown 2. Click in the text area and then try to make your edits 3. Click save to save your edits.

Which step is causing the problem or which step can’t you do? What exactly are you seeing? What browser are you using? This should not be affected by your import limit. It must be something else causing the problem. Any more information you can provide will be helpful.

I followed your instructions:

  1. I went to the Imports section, fond the lesson I want to edit and clicked on the Edit lesson option in the lesson dropdown
  2. I clicked in the text area and then tried to make my edits… but I can’t change or delete anything. I can only edit the description and the title.

This is what I see: https://dl.dropbox.com/u/1028855/textarea.png

I tried with 2 other lessons and there’s no problem, I can edit them. The only apparent difference is that this one is private and the others are shared.
I usually use Firefox 16.0.2 but I also tried Chrome and the problem persists.


@mfr - Ah, that would explain it. Since you’ve hit the limit for private imported lessons, you won’t be able to edit any private lessons. If you share this lesson then you will be able to edit the text. Let us know if you still run into problems with this.

I don’t understand. Isn’t 5 the limit for private imported lessons? If I have only one private lesson, how can I have reached the limit?

@mfr - The limit on private imported lessons is a hard limit, meaning adding 5 and removing one doesn’t free up another spot.

I still don’t understand. I didn’t delete any lessons; all the other lessons I have are shared. and only one (1) is private.

Well, it really doesn’t matter, I was just testing an external audio source. But I still think the sums do not add up.

Fernanda, what can we do to help? Any lesson that you share in the Library does not count against your limit as a free member. Are you sure that you have no other shared lessons? I would like to make sure you can continue to contribute your Portuguese lessons.

I have a problem (I think) that I’ll tack on to this thread. I’m importing Slow German podcasts for my own use. I paste the URL for the recording into the external audio source box. When I open the lesson, I see a message that says “download audio” instead of the player button. And when I click the message I am taken to the page where, of course, I hear the audio but can’t see the lesson anymore.

Is there something I can do differently so that I stay on the LingQ page?

(I realize that, if need be, I can open two tabs at the same time…)

Hi Steve
I have 4 shared courses, with a total of 47 shared lessons, and 1 private lesson.
This is what I see:

By the way, under “In use” what’s the meaning of those numbers?

I’m trying to find out about copyright of Portuguese radio podcasts. That’s why I created this lesson with an external link, just to test how it was done.
I found a course shared by smeeth which is RTP Falamos Português - Login - LingQ
How was copyright granted in this situation?


Fernanda, we will look at what is happening. I can see that you only have one private lesson. I don’t think that is the issue.

“In use” means the number of times a member has selected this lesson to study.

We rely on members to make sure that they have permission to use any material they contribute. I suggest you contact the content provider (smeeth) and ask him what he did.

@mfr - This is related to the import limit. You will have to share the lesson first and then quickly update the text. Sorry about that. We do plan on resolving these issues in the future but for now you will have to do it this way.

Thanks for the tip and for the time taken.

yes, I will contact smeeth.

@Jingle - We are aware of this issue and are working to resolve it.