Editing of source word while adding to the LingoQ dictionary not possible


When trying to edit a source word (for example because it is in a grammatical form not suitable for your purposes and you want to change it in its official form), it is not possible by clicking the pencil icon next to the word. May be there is a button that allows this, but I couldn’t find it. Also, I tried to edit the word on the list of words that appears after clicking the pencil button in the panel My Lingqs. The pencil button there works and I managed to edit the word, however, after clicking the Save button the word was deleted from the list (other result of my multiple tries to edit it was that the word appeared on the list but was not edited).

Please advice how to solve this problem. Thank you in advance.

This should be working properly, though keep in mind that only LingQed terms that show up in the lesson itself will appear in the list in the dashboard. If you look at all your terms on the Vocabulary page, however, you should see that this LingQed term is still there in your database.

I might recommend saving multiple LingQs for different forms of the same verb, etc. This may seem repetitive, but it is in fact a great exercise and that repetition helps you learn the word and multiple forms of the word better.

Thanks alex!

The terms are actually from a lesson.
Now they are already in their edited form! May be it needs time to be updated!

I don’t know if this is the right place but may I propose two ideas:

  1. The export of words is allowed only in csv format – may be it will be useful for somebody to have more options for the export format.
  2. The function for picture next to the new word allows to add pictures only from your desktop. May be it will be more friendly to add them also directly from the Internet.


@kadiva1 - Yes, the edit pencil beside the term should be working. It is not working now and is a bug we are looking into. In the meantime, you can edit terms the way you describe. I might suggest adding the different forms on their own instead of editing the form you LingQed. The reason is that once you edit the term it will no longer be highlighted in the text you are reading. This is simply because once the term is edited, it is no longer in the text. We believe that you should LingQ all forms of word or verb separately since they are all different words and you must learn to recognize them all rather than trying to save the infinitive which appears much more rarely on its own.

We have no plans to add formats for vocabulary export but we will keep it in mind. Yes, it would be nice to add pictures from the internet. We will add this to our wishlist.

Thank you very much for the prompt and detailed explanation @mark! I’ll try to find my own way.