Can't send Conversation report

It’s been a few days now, I can’t send the conversation report since last Monday.
When I send it I get this error:
An error has occurred while processing your request. Depending on the type of error, it may be automatically logged and reviewed by our team so please retry your request in a few minutes. If you are still getting this error message after a few minutes, please email us at support@lingq.com.

I reported it yesterday. They say they’re working on it.

Yes, the same with me.
I tried many times - and I received ‘Error 500’ again and again.
But it’s also interesting - my student said that he said already 5 times the same report - all my tryings!
It doesn’t work in the system, so I can’t receive any points, but my student has received this report all times I pressed ‘send’…

Sorry about that everyone! This issue has been fixed and the fix will be on production soon. Thanks for your patience.

Ok thank you zoran. It works now!

Yes, the fix is on production now. Sorry once again everyone!