An icon doesn't show up

Obviously it’s not a great problem, but I’ve noticed it and just thought it could be useful to report it.

Tomorrow I’ve got my first conversation in Polish (as a tutor) and on the speak page I can see the following:

  • “12:00 - 1 on 1 conversation”
  • the name of the student
  • a yellow icon resembling a human (what does it tell me?)
  • some icon that doesn’t show up
  • “15 minutes”

The thing that bothers me is the icon that doesn’t show up :wink: What should I be able to see there? And why I can’t? Is there something wrong on my side?

The icon resembling a human is showing that you are the host of the conversation. The icon that doesn’t show up is the flag of the user’s country.

As Vera says, this is the flag of the user’s country. Can you right-click the broken image, copy the image URL then post it here?

Also, has anyone else noticed a problem for other countries?

@VeraI: Thanks Vera! That was what I expected.

@alex: Ok, here is the URL:

Being “the student”, I have the same problem. Moreover, I don’t even see the tutor icon (it just reads “Polish”).

I know that a few time ago, the Czech flag was not displayed on the “Send a writing” and “Request a conversation” field, but I just saw it there. Maybe it’s still missing on the Speak page. The Latin flag was also missing a few days ago.

I have just tried to replace “pl” with the “cs” and “la” endings in the link given by Piotr, and they don’t seem to exist, either.

By the way, “cs” stood for Ceskoslovensko. It may have been better to use “cz” instead… But I guess nobody else noticed this, so I won’t urge you to change it! :slight_smile:

@mike bond - you won’t see the tutor iconif you are the student. That icon is there to identify conversations you are tutoring as opposed to conversations you are a student for. We are aware of the cs vs. cz issue. Somehow both prefixes have been used on the site. We are working at resolving all the flag issues.

Of course, Mark, you are right. I am just so used to seeing the tutor icon, since I have only been hosting conversations, lately.

In case you didn’t notice, the flags should all now be working properly. Please let us know if you encounter any more problems.

Yes, Alex, all the flag are displayed now. I see you put the Vatican flag for Latin in the “Send a writing” and “Request conversation” templates. Now, the same flag should be put in the dropdown menu to select languages, to avoid any confusion.
Good job, anyway!