Adding meaning to new words

The app works great for me on my iphone and my ipad. In the browser however I am unable to add a meaning to a new word. If it’s a word I’ve already encountered then I can edit the meeting in the browser but if it’s a work I haven’t encountered then that field to add meaning is just missing. I have tried in both Chrome and Firefox and I’ve been trying for weeks now hoping that an update would fix this.

Am I the only one experiencing this issue? is this something that is being worked on? I do enjoy the mobile apps for their portability but for a longer session I’d much rather use my PC, unfortunately that’s not possible at the moment.

It seems fine on my end. I asked our team to check that and will let you know if we find any issues.

Hi @deltasalmon,

Sometimes adding new meanings to newly encountered words can be tricky (with the differences between mobile and the web browser), so I wanted to make sure.

Have you tried these steps and is it still not working for you?:

  1. Navigating to the page you want → clicking on the blue word you want to define:

  1. Clicking on the arrow down carrot :arrow_down_small: :

  1. Typing into the “Type a new meaning here” box:

  1. Hitting your enter/return key so the new meaning displays like this (grey in color):

Note: I included a bit more info in case a future user might benefit from these screenshots, not saying you missed something. (I hope that’s clear. :slightly_smiling_face: )

Just because: Images for Users wanting to add a new meaning to a word via mobile (Android)
  1. Navigate to the page you want → click on the blue word you want to define:

  1. Swipe up on the popup box for the new blue word you clicked:

  1. Type in the New Meaning of your clicked-blue word in the “Type new meaning here” box:

  1. Click the check mark to confirm your new meaning (:ballot_box_with_check:):

Note: Directions included to help others (if they need it) because it took a bit for me to figure out the shortcut of swiping up on the popup, lol. Please ignore if this is unhelpful to your use case.

1 Like

Hi! I’m using Firefox and what happens is that the first time I encounter an unfamiliar word and click on it, the only option is to go with the default definition. But when I click the word a second time, it works great. I can edit that definition or look at other definitions to see if any of those will work, or click on a dictionary, or add my own new definition.

So I’ve just gotten into the habit of: click the new word, select the default definition, close out, then click the new word a second time, and then finally do whatever is needed to get a good working definition.

Hi @WillowMeDown,

I use a few different browsers: Chrome, Edge, and Firefox (for various reasons, lol). I just wanted to give the heads-up that the above instructions for the browser should also work for you.

I just checked on Firefox.

Hm… I’m not sure what happened but I opened up a new word to see if I was missing the little arrow you mentioned and when I did it this time the blank box for new meeting showed up without having to click an arrow or anything. This is in Firefox, I haven’t tried it in other browsers but as long as it works in Firefox I’m happy. Thanks!

@deltasalmon I want to say I have noticed this myself (off/on), but it’s not always consistent:

I think what you’re discribing might be the default for new words/LingQs that the LingQ community has never defined. Not sure, though.

I think the default behavior is for it to display a machine translation. (Lately it often seems to display two: presumably Google Translate, and DeepL?)

But I have also encountered a completely blank display. I think that happens when there’s a temporary interruption to the connection to either the Internet, LingQ’s server, or possibly some third thing?

I do see the blank box.

But what I don’t see is the little down-arrow that allows me to look at all the different definitions. This doesn’t show up until I click the word the second time. Often the first definition isn’t the one I need, and sometimes it’s not in the available dictionaries either (for example, 내주 was coming up in the dictionaries as “next week” but the definition I needed was “dwell”), but when I am able to scroll through the definitions added by others (the second time I click the word) I can usually find useful information.

1 Like