500 - Server error

I open my lesson and click “Edit Lesson” and “Save”. Then, it appears 500 - Server error on my screen. I can’t edit my lesson.

I tried this and it seemed to be working properly. Can you email the Share URL (found at the bottom if you open the lesson) to LingQ Support so we can take a look at it?

It’s only two lessons that I can’t edit. I don’t know why. I deleted two items.

If I have the URL of the lessons I will be able to better assist you. :slight_smile:

I get the same error, but just when I try to load Login - LingQ (for the last 2 days at least)

@berta - We’ll have to look further into why you are receiving this error, as it appears to be working fine for us.


We are looking into the issue behind these various issues now. Any additional reports of what went wrong and where would be helpful!

Oh well!

Well this is very weird!. I don’t have any problem accessing the points page with my other accounts (btw I use Chrome and Safari on a Mac), but when I try to access the points’ page with this account (berta) I always get the 500-server error.

As you say, the issue seems to only be affecting some accounts. It’s likely not a problem based on the browser, but we’re still hunting it down.

I have been sharing several lessons without any problems these days.
However, today, after saving some lessons correctly, I cannot save one which was already shared (I just wanted to change the level and add the provider - I realized I hadn’t made a provider page for myself in the English library). Whatever I change, when I press “Save”, I get the “500 - Server error” message.
I hadn’t got this message for ages, so I wonder what’s happening now! :slight_smile:

I think I made a mistake… I wanted to unshare that lesson and try to change the level and the provider once it was unshared, but it seems I deleted it, since I cannot find it in my “Import” page either. :frowning: Can you restore it?

I don’t know what’s happening. Now I have copied and pasted the text, uploaded the audio, set the level and the provider, and shared that same lesson correctly. The only problem is that the lesson I accidentally deleted was used by more than 30 learners…

I don’t get that error anymore, thank you

This error should be fixed now. Please let us know if you still encounter it!

@mikebond - Unfortunately, once a lesson is deleted it is deleted. Make sure to read the dialogue boxes that pop up to ensure you’re performing the right action!

Alex, I don’t remember reading any dialogue box when I pressed that button… Anyway, I thought that “Remove from the library” meant “Unshare” not “Delete”.

I have now realized that those lessons imported from writing reports sometimes have too long titles. I didn’t think of it before, because, when I save a lesson with too long a title, I don’t usually get “500 Server error”, but a message within the Importing template saying something like “Titles must have a max. of 65 characters. Yours has…”.
Well, luckily I could import and share that writing again…

Ah, I see what you mean now. The lessons shows as “Deleted” but it actually isn’t deleted. Either way, this does appear to be an error and we’ll look at getting it fixed.

Well, if it isn’t deleted and can be restored, that’s good news!

Thanks for your hard work. :slight_smile: