”Points" does not reflect my purchase

Excuse me, but I purchased points, and received the invoice from LingQ. But my “Points” icon shows still 220. The very same problem happened to me about a month ago. At that time a half day later I got the points. so I hope everything is fixed while I am sleeping…

Please try refreshing the page. Everything shows up properly on our end. Your points have been added to your account.

Thank you for your quick reply, Mark. But “Points” still shows 220 no matter what I do. I will check it out next morning. Then I will report it to you if I still have the same problem. おやすみなさい。

That’s very strange. Why don’t you try ctrl + refreshing your browser. Or, better yet, try to spend some points and see if that fixes things.

Dear Mark,

Thank you for yesterday. The following is my report.

1 I didi ctrl + r to refresh my browser many times.
→ didn’t work.

2 I tried to sign up for a class of my tutor.
→ “You need to buy more points” dialogue appeared. didn’t work.

3 I bought another 10 points, wishing something would happen.
→ didn’t work.( but I got the invoice.)

4 I went to bed, giving up everything. →It seems to have worked…

I got up and came to LingQ. Wow, what I saw was…everything had been fixed!!! Anyway thank you for your quick and kind response as usual.